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Warranty

The material contained in this docu-
ment is provided “as is,” and is sub-
ject to being changed, without notice, 
in future editions. Further, to the max-
imum extent permitted by applicable 
law, Agilent disclaims all warranties, 
either express or implied, with regard 
to this manual and any information 
contained herein, including but not 
limited to the implied warranties of 
merchantability and fitness for a par-
ticular purpose. Agilent shall not be 
liable for errors or for incidental or 
consequential damages in connec-
tion with the furnishing, use, or per-
formance of this document or of any 
information contained herein. Should 
Agilent and the user have a separate 
written agreement with warranty 
terms covering the material in this 
document that conflict with these 
terms, the warranty terms in the sep-
arate agreement shall control.

Technology Licenses 
The hardware and/or software described in 
this document are furnished under a license 
and may be used or copied only in accor-
dance with the terms of such license.

Restricted Rights Legend
If software is for use in the performance of a 
U.S. Government prime contract or subcon-
tract, Software is delivered and licensed as 
“Commercial computer software” as 
defined in DFAR 252.227-7014 (June 1995), 
or as a “commercial item” as defined in FAR 
2.101(a) or as “Restricted computer soft-
ware” as defined in FAR 52.227-19 (June 
1987) or any equivalent agency regulation or 
contract clause. Use, duplication or disclo-
sure of Software is subject to Agilent Tech-
nologies’ standard commercial license 
terms, and non-DOD Departments and 
Agencies of the U.S. Government will 
receive no greater than Restricted Rights as 
defined in FAR 52.227-19(c)(1-2) (June 
1987). U.S. Government users will receive 
no greater than Limited Rights as defined in 
FAR 52.227-14 (June 1987) or DFAR 
252.227-7015 (b)(2) (November 1995), as 
applicable in any technical data.

Safety Notices

CAUTION

A CAUTION notice denotes a hazard. It calls 
attention to an operating procedure, prac-
tice, or the like that, if not correctly per-
formed or adhered to, could result in 
damage to the product or loss of important 
data. Do not proceed beyond a CAUTION 
notice until the indicated conditions are 
fully understood and met. 

WARNING

A WARNING notice denotes a hazard. It 
calls attention to an operating procedure, 
practice, or the like that, if not correctly per-
formed or adhered to, could result in per-
sonal injury or death. Do not proceed 
beyond a WARNING notice until the indi-
cated conditions are fully understood and 
met.
Trademark Information
Visual Studio is a registered trademark of 
Microsoft Corporation in the United States 
and other countries.

Windows NT is a U.S. registered trademark 
of Microsoft Corporation.

Windows and MS Windows are U.S. regis-
tered trademarks of Microsoft Corporation.

Software Revision

This guide is valid for Revisions 14.xx of the 
Agilent IO Libraries Suite software, where 
xx refers to minor revisions of the software 
that do not affect the technical accuracy of 
this guide.
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1
Quick Start

This chapter gives you the information you will need, in 
most cases, to configure connections to your instruments 
and interfaces and start using the Agilent IO Libraries to 
communicate with your instruments. The Quick Start steps 
detailed in this chapter are:

1 Install IO Libraries Suite Software

2 Connect and Configure Interface and/or Instrument 
Hardware

3 Run Connection Expert to Verify I/O Configuration
Who Should Install the IO Libraries Suite?
If you plan to connect your instrument(s) to a PC, you 
should install the Agilent IO Libraries Suite. This will help 
you configure your system in order to control your 
instruments from the PC and/or transfer data to the PC. If 
you are using Agilent instrument drivers, Agilent IntuiLink 
connectivity software, or other application software, you 
should first install the IO Libraries Suite to provide support 
for the application software and instrument drivers.

Some Agilent application software and some Agilent drivers 
install the Agilent IO Libraries, or a subset of the IO 
Libraries. In this case, you should still install the IO 
Libraries Suite to ensure that you have up- to- date software 
and all the IO Libraries Suite utilities for configuration and 
troubleshooting.

If you bought an Agilent instrument, and received the 
Automation- Ready CD with Agilent IO Libraries Suite 
along with an additional application CD- ROM (such as an 
IntuiLink CD), you should always install the 
Automation- Ready CD first. 
5Agilent Technologies
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IO Libraries Suite Quick Start Steps

1. Install IO Libraries Suite Software
6

a Perform pre- installation checks:

•Make sure your PC meets the minimum system 
requirements. (See “System Requirements” on 
page 28.)

b Install IO Libraries Suite: 

•Close all other applications on your PC, insert the 
Automation- Ready CD with Agilent IO Libraries 
Suite into your CD- ROM drive, and follow the 
instructions on your screen.

•If the IO Libraries Suite installation does not start 
automatically, select Start > Run (on the Windows Start 
menu) and type <drive>:\autorun\auto.exe, 
where drive is your CD- ROM drive.

•After IO Libraries Suite has been successfully 
installed, you will see the IO Control (IO icon) in the 
taskbar notification area on your PC screen as in 
Figure 1. (The taskbar notification area is where the 
clock is usually displayed.)

•If you have difficulty with the installation, see 
Chapter 3, “Installing IO Libraries Suite”.

Figure 1 IO Control icon in taskbar notification area 
Agilent IO Libraries Suite Getting Started
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2. Connect and Configure Interface and/or Instrument Hardware
Agilent IO Libraries Suite Getting St
If you are not installing new hardware (interface cards, 
converters, or instruments), skip this section and proceed 
directly to step 3.

a Install hardware: If you received the Agilent IO 
Libraries Suite when you purchased an instrument or 
an interface product (such as an Agilent GPIB card or 
USB/GPIB interface converter), it is time to install the 
hardware now. Consult the documentation for your 
hardware product for installation instructions and 
specific hardware configuration (for example, setting 
Ethernet or GPIB addresses). General instructions for 
hardware installation appear in the Agilent 
Connectivity Guide, which you can display (in PDF 
format) by clicking the IO Control and choosing 
Documentation > Connectivity Guide. The Documentation 
menu also includes manuals for Agilent interface 
hardware products that you have installed.

b Configure hardware; turn on the PC if necessary: If 
you turned your PC off to install new hardware, turn it 
back on when the installation is complete, and wait for 
your PC to start up. Perform any necessary hardware 
configuration.
3. Run Connection Expert to Verify I/O Configuration

NOTE When you connect a USB device, Windows will display a Found New 
Hardware Wizard. If your USB device is an Agilent USBTMC instrument or 
an Agilent USB/GPIB Interface Converter, you do not need to insert a CD 
when prompted by the wizard, because all the drivers you need have 
already been installed with the IO Libraries Suite. Simply click Next until 
the wizard completes. If a second Found New Hardware Wizard appears, 
continue to click Next until that wizard completes as well. These wizards 
place the installed USB drivers in the appropriate locations for Windows to 
recognize your device.
a Run Connection Expert: If the Connection Expert 
utility does not run automatically at this time, click the 
arted                           7
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IO Control (IO icon in the Windows notification area) 
and then click Agilent Connection Expert.

b Change the I/O configuration if necessary: Connection 
Expert will automatically detect most interfaces and 
instruments, and will assign names and other default 
configuration settings. If you want to change these 
parameters, you can do so in the Connection Expert 
window. 

•Select the instrument or interface in the explorer 
pane in the center of the Connection Expert window.

•The properties of the selected item appear in the 
properties pane on the right. When you right- click on 
an item in the explorer pane, you see a shortcut 
menu of actions that you may take on that item. 
These actions are also available from the menus at 
the top of the Connection Expert window. The most 
common actions are also listed in the Connection 
Expert’s task guide (the left pane of the window).

•You may also add instruments or interfaces manually 
to your test system configuration if Connection Expert 
does not automatically detect the hardware (for 
example, if it is connected via Ethernet or via serial 
port).

•See the Agilent IO Libraries Suite Online Help for 
more information on Connection Expert and on 
configuration changes.

c Test instrument connections:

•Connection Expert will automatically send an 
identification query (*IDN?) to any instrument that 
has its auto- identify property set to Yes. (See the 
Agilent IO Libraries Suite Online Help if you want to 
turn this function off.) 
Agilent IO Libraries Suite Getting Started
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Agilent IO Libraries Suite Getting St
•When you see a green check mark on the 
icon representing an instrument, this 
means that the instrument has responded 
as expected. (Note that some instruments 
do not support the *IDN? query and will 
not respond appropriately.) The instrument’s 
identification information is displayed in the 
properties pane on the right side of the Connection 
Expert window. 

•You can explicitly test the connections to your 
instruments, and exercise more of their functionality, 
by selecting Send commands to this instrument in the task 
guide or shortcut menu. This starts the Interactive IO 
utility, which allows you to send commands to your 
instruments and see their responses. Note that some 
commands (such as *TST?, instrument self- test) may 
take longer than Interactive IO’s default timeout; you 
can modify the timeout in the Interactive IO window 
by selecting Interact > Options...
4. Optional: Install additional software
If you received the Automation- Ready CD with an Agilent 
instrument or interface product, you may also have received 
a second CD- ROM containing additional software and 
information related to your product. This CD may contain 
software such as instrument drivers, specialized applications, 
or sample programs. Consult the documentation that came 
with your hardware for complete software descriptions and 
installation information.
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2
Welcome to Agilent IO Libraries Suite

This chapter includes:

• What is Agilent IO Libraries Suite?

• Where Can I Get More Information about Using Agilent IO 
Libraries Suite?
11Agilent Technologies



2 Welcome to Agilent IO Libraries Suite
What is Agilent IO Libraries Suite? 
12
Agilent IO Libraries Suite is a collection of libraries that give 
you the ability to use your instruments from a test and 
measurement program, and utilities that help you quickly 
and easily connect your instruments to your PC.

Agilent IO Libraries Suite speeds your success with software 
utilities that let you quickly connect your instruments to 
your PC, configure and verify your connection, and get on 
with your job — whether that entails programming 
instruments or using pre- existing application software. For 
test and measurement programmers, Agilent IO Libraries 
Suite brings the power of the industry- standard VISA and 
VISA COM libraries, as well as SICL and Agilent 488, to your 
programming experience.

Below you will find an illustration and a list of the 
components (libraries and utilities) that make up the Agilent 
IO Libraries Suite product. You can find more information 
about each of these components in the Agilent IO Libraries 
Suite Online Help.
NOTE To access the Agilent IO Libraries Suite Online Help from the Connection 
Expert window, click Help > Help Topics on the menu bar or press the F1 
key. To access the online Help without running Connection Expert, click 
the IO Control (IO icon in the taskbar notification area), click 
Documentation and then IO Libraries Suite Help.
NOTE To find out where the Agilent IO Libraries Suite components listed below 
have been installed on your system, click the IO Control (IO icon in the 
Windows notification area), then click Installation Information.
Agilent IO Libraries Suite Getting Started
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Agilent
IO Libraries

Agilent
488

SICL
VISA
COM

VISA

Remote IO
Server

ViFind32

Interactive
IO

VISA
Assistant

VXI
Resource
Manager

Agilent
Connection

Expert

Agilent
IO Control
Figure 2 Libraries and utilities that make up Agilent IO Libraries Suite. 
The Agilent Connection Expert and Agilent IO Control provide access 
to the other IO Libraries Suite utilities, as shown by the arrows.
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Agilent IO Libraries
14
There are four IO Libraries included in Agilent IO Libraries 
Suite; each of them allows you to programmatically control 
instruments, send commands to them, and receive responses 
and data. The Agilent IO Libraries Suite Online Help 
provides guidelines to help you choose among these libraries; 
in general, VISA and VISA COM are recommended for new 
development.

Agilent VISA 

Agilent VISA (Virtual Instrument Software Architecture) can 
be used to develop I/O applications and instrument drivers 
that are interoperable with many other VISA applications 
from many vendors, and that comply with IVI Foundation 
standards (formerly VXIplug&play standards).

Agilent VISA COM

Agilent VISA COM is a COM (Microsoft Common Object 
Model) implementation based on the Agilent VISA 
architecture. Like VISA, VISA COM conforms to IVI 
Foundation standards. 

Agilent SICL

Agilent SICL (Standard Instrument Control Library) is an 
I/O library developed by Agilent that is portable across 
many instrument I/O interfaces.

Agilent 488 

Agilent 488 is a GPIB I/O library provided by Agilent for 
compatibility with existing test & measurement programs 
that were developed using National Instruments’ NI- 488 or 
other similar libraries.
Agilent IO Libraries Suite Getting Started
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Agilent IO Libraries Suite Utilities
Agilent IO Libraries Suite Getting St
The IO Libraries Suite includes a number of utilities to help 
you connect, configure, and troubleshoot your test system. 
These utilities, described on the next several pages, include:

• Agilent Connection Expert

• Interactive IO

• IO Control

• Remote IO Server

• ViFind32

• VISA Assistant

• VXI Resource Manager

Agilent Connection Expert

Connection Expert is a software utility that helps you 
quickly get your instruments connected to your PC and 
troubleshoot connectivity problems. You can use Connection 
Expert to:

• configure instrument I/O interfaces

• automatically discover instruments that are connected to 
your PC or to the local subnet of your local area network

• specify connections to instruments that are on your local 
area network beyond the local subnet

• browse the structure and connections of your test system 
(including your PC, instruments, and interfaces)

• detect and troubleshoot connectivity problems in your test 
system

• create programming aliases that you can use in place of 
addresses to improve portability and readability of your 
test program

Connection Expert includes a task guide (the left pane of the 
utility’s window) that provides shortcuts to common tasks 
and information.
arted                           15
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Figure 3 Agilent Connection Expert

To run Connection Expert, click the IO Control (IO icon in 
the Windows notification area), and click Agilent Connection 
Expert.

You must have Administrator privileges to run Connection 
NOTE Expert.
Agilent IO Libraries Suite Getting Started
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Interactive IO

Agilent Interactive IO is a software utility that allows you to 
interact with an instrument by sending commands to the 
instrument and seeing the instrument’s responses. You can 
use Interactive IO to:

• quickly verify connectivity to your instrument

• troubleshoot communication problems

• learn the instrument's command set

• rapidly prototype commands and check the instrument's 
responses before writing code

With Interactive IO, you can choose from a menu of common 
commands (listed in Table 1) or type in commands that are 
specific to your instrument.

To start Interactive IO from within Connection Expert, click 
Tools > Interactive IO from the Connection Expert menu bar or 
click Send commands to this instrument on the task guide. You 
can also start Interactive IO from the IO Control by clicking 
the IO icon in the Windows notification area and then 
selecting Interactive IO.

Note that some commands (such as *TST?, instrument 
self- test) may take longer than Interactive IO’s default 
timeout; you can modify the timeout in the Interactive IO 
window by selecting Interact > Options...

Figure 4 Interactive IO
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Table 1 Interactive IO Common Commands

IO Control

When you install Agilent IO Libraries Suite, the Agilent IO 
Control is displayed as a circled IO symbol in the Windows 
notification area. The IO Control provides easy access to the 
IO Libraries Suite utilities and documentation.

When you click the IO Control, you will see a menu that 
includes several types of commands:

Command Description

*IDN? The Identification query returns manufacturer, model, serial 
number, and firmware level or equivalent.

*CLS The Clear Status command clears status data structures, and 
forces the device to the Operation Complete query idle state.

*OPC? The Operation Complete query places an ASCII character “1” 
into the device’s Output Queue when all pending selected 
device operations have been finished.

*RCL The Recall command restores the current settings of a device 
from a copy stored in local memory.

*RST The Reset command performs a device reset, which sets the 
device-specific functions to a known state that is 
independent of the past-use history of the device.

*SAV The Save command stores the current settings of the device 
in local memory. 

*STB? The Read Status Byte query returns the status byte and 
master Summary Status bit.

*TRG The Trigger command signals the transition of the Device 
Trigger (DT) function to the Device Trigger Active State 
(DTAS).

*TST? The Self-test query returns zero to indicate the test 
completed with no errors. A return value not equal to zero 
indicates the test is not completed or completed with errors.
Agilent IO Libraries Suite Getting Started
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• Commands to run each of the Agilent IO Libraries Suite 
utilities: Connection Expert, Interactive IO, VXI Resource 
Manager (if applicable to your system), ViFind32, and 
VISA Assistant

• An Event Viewer command to invoke the Microsoft Event 
Viewer, which can be useful in debugging I/O programs

• A Documentation submenu with commands to display:

• online Help files for IO Libraries Suite and for specific 
IO Libraries 

• manuals for IO Libraries Suite, specific IO Libraries, 
and Agilent interface products

• the Agilent IO Libraries Suite Read Me file

• installation and path information, which includes paths 
for Agilent IO Libraries Suite and for Agilent VISA, and 
Windows registry entries used by Agilent IO Libraries 
Suite

• An Agilent VISA Options submenu with commands to set the 
Logging and LockWait options for the Agilent VISA 
library.

Figure 5 IO Control Menu
NOTE If the IO Control icon is not visible, you can display the icon by clicking 
Start > Programs > Agilent IO Libraries Suite > Utilities > IO Control or, 
in Connection Expert, View > IO Control.
Remote IO Server

The Remote IO Server software provides a way to connect 
via local area network (Ethernet) to instruments that are 
physically connected to another PC on the network. When 
the Remote IO Server is running on one PC (the server), you 
can use instruments connected to that server from other PCs 
(the clients) by using the Connection Expert to create 
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remote interfaces on the client PCs. See the Agilent IO 
Libraries Suite Online Help for details.

ViFind32

ViFind32 is a console application that uses the viFindRsrc 
and viFindNext VISA functions to enumerate all resources 
visible to VISA. This application is useful for verifying that 
all expected interfaces have been configured by Connection 
Expert, and that the expected devices have been attached.

To run ViFind32, you can do any one of the following:

• Click Start > Programs > Agilent IO Libraries Suite > Utilities > 
ViFind32 

• Click the IO Control, and then click ViFind32

• In Connection Expert, click Tools > ViFind32

VISA Assistant

The VISA Assistant utility is provided for your convenience, 
though most of its capabilities have been replaced by 
Interactive IO and Connection Expert.

VXI Resource Manager

The VXI Resource Manager is a software utility that 
initializes and prepares a VXI system for use. If your system 
includes an E8491 IEEE- 1394 PC Link to VXI interface, you 
can use the VXI Resource Manager to determine whether 
your system is properly configured.

The VXI Resource Manager runs when any of the following 
conditions occurs:

• You start it from the Connection Expert’s Tools menu 
(select Tools > VXI Resource Manager > Edit Resources, then 
click Run in the resulting Resource Manager dialog box)

• You start it from the Agilent IO Control

• You apply or cycle VXI mainframe power 

• You press the E8491 Reset button
Agilent IO Libraries Suite Getting Started



Welcome to Agilent IO Libraries Suite 2

Agilent IO Libraries Suite Getting St
• You reboot your PC 

In VXI systems with multiple E8491 interfaces, you can turn 
off individual VXI mainframes without affecting other 
mainframes in the system. When a mainframe is turned on, 
the VXI Resource Manager reconfigures that mainframe.
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Where Can I Get More Information about Using Agilent IO Libraries 
Suite?

Agilent IO Libraries Suite Documentation
22
Online Help

Online Help is always easily available whenever you use the 
Connection Expert software. Just click Help > Help Topics. The 
online Help will appear on your screen in a new window. 

Figure 6 Agilent IO Libraries Suite Help

• Click any book icon to see the topics beneath it. 

• When a book or chapter is open, it looks like this: 
Agilent IO Libraries Suite Getting Started
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• Each topic is represented by a symbol like this:

• When Connection Expert is running, you can press F1 in 
any Connection Expert pane or dialog box to go directly 
to the most relevant help topic. 

• When Connection Expert is not running, you can view the 
online Help by clicking the IO icon in the taskbar 
notification area (the IO Control) and then clicking 
Documentation > IO Libraries Suite Help.

The Task Guide

The Connection Expert task guide appears in the left- most 
pane of the Connection Expert window. The choices listed in 
the task guide are based on what you have selected in the 
explorer pane (the middle pane of the Connection Expert 
window). The purpose of the task guide is to point you to 
common tasks and useful information. 

Other Documentation

The table below lists documentation that may be helpful to 
you as you connect and control your instruments.

nd Related Documentation
Table 2 Agilent IO Libraries Suite a

Document or helpful information Description

Agilent IO Libraries Suite Getting Started This is the electronic manual you’re now reading. It provides an 
introduction to IO Libraries Suite features and installation instructions.

Agilent USB/LAN/GPIB Connectivity Guide This electronic manual provides step-by-step instructions on connecting 
instruments to PCs via USB, LAN, or GPIB, with troubleshooting techniques 
and programming information.

Agilent IO Libraries Suite Online Help This Help file provides general Agilent IO Libraries Suite information and 
specific information on usage of the Connection Expert utility. Includes 
detailed troubleshooting techniques and high-level programming 
information. In Connection Expert, click Help > Help Topics, or use the IO 
Control Documentation menu.
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Web Resources

VISA Online Help 
VISA COM Online Help 
SICL Online Help 
Agilent 488 Online Help

These Help files provide programming reference information in the form of 
Windows HTML Help. In Connection Expert, click Help > Help Topics, or 
use the IO Control Documentation menu.

VISA Users’ Guide 
SICL Users’ Guide

These electronic manuals provide introduction to I/O programming 
concepts, library details, and step-by-step instructions to build sample 
programs. In Connection Expert, click Help > Documentation, or use the IO 
Control Documentation menu.

Agilent IO Libraries Suite Task Guide This guide appears in the left-most pane of the Connection Expert window. 
The task guide lists common tasks and helpful information; the choices are 
based on what you have selected in the explorer pane (middle pane).

Programming Samples Agilent IO Libraries Suite provides sample programs online to help you 
develop VISA, VISA COM, and SICL applications. Access these samples 
from Connection Expert by clicking Help > Programming Samples. 
Additional sample code is available on the Agilent Developer Network (see 
below).

Table 2 Agilent IO Libraries Suite and Related Documentation
24
Agilent Developer Network (ADN)

The ADN Web site provides code samples, software downloads including IO 
Libraries Suite updates and instrument drivers, technical notes, white papers, and 
other resources for software developers. The URL for ADN is 
http://www.agilent.com/find/adn

Application Central

Application Central provides hundreds of application notes, 
technical notes, tutorials, and application hints. You can find 
Application Central at

http://www.agilent.com/find/appcentral

Test & Measurement Software and Connectivity Products

You can find product information on interface cards, 
converters, and connectivity software at

http://www.agilent.com/find/connectivity
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Contacting Agilent
Agilent IO Libraries Suite Getting St
In the USA, you can reach Agilent Technologies at this 
telephone number:

USA: 1- 800- 829- 4444 

Outside the USA, contact your country’s Agilent support 
organization. A list of contact information for other 
countries is available on the Agilent Web site:

http://www.agilent.com/find/assist
arted                           25
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3
Installing IO Libraries Suite

This chapter includes:

• System Requirements

• Installing the IO Libraries Suite Software

• Optional: Installing Additional Software For A New 
Instrument Or Interface

• Installation Troubleshooting

• Keeping Your Software Up To Date
NOTE This chapter assumes that you are installing Agilent IO Libraries Suite 
from the Automation-Ready CD. If you are installing from the Web, 
double-click the downloaded executable to extract files and launch the 
setup program; then proceed with the software installation as 
documented in this chapter.
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• Processor: 450 MHz Pentium II or higher required, 800 
MHz recommended

• Operating system: One of the following Microsoft 
Windows versions:
• Windows XP Professional or Home Edition, Service 

Pack 1 or later
• Windows 2000 Professional, Service Pack 4 or later 

• Browser: Microsoft Internet Explorer 5.01 or greater

• Available memory: 128 MB (256 MB or greater 
recommended)

• Available disk space:

225 MB required for installation:
• 160 MB for Microsoft .NET Framework
• 65 MB for Agilent IO Libraries Suite

175 MB required for operation:
• 110 MB for Microsoft .NET Framework
• 65 MB for Agilent IO Libraries Suite

• Video: Super VGA (800x600) 256 colors or more

If possible, you should use the current version of the Agilent 
IO Libraries Suite. This version supports the newest 
interfaces and operating systems, and has the most advanced 
features. However, you may need an earlier version of the IO 
Libraries Suite to support an older interface or operating 
system. For example, Agilent IO Libraries Suite 14.0 is 
needed to support Windows 98SE or Windows Me.

If you have the Automation- Ready CD with Agilent IO 
Libraries Suite 14.1, you can install version 14.0 directly 
from the CD- ROM. In Windows Explorer, navigate to the 
folder called Previous Versions on the CD- ROM. Double- click 
the file IOLibSuite14_0.exe to install version 14.0.

If you need a version earlier than 14.0, or if you do not 
have the Automation- Ready CD, go to: 
http://www.agilent.com/find/iolib  
to locate the version you need. 
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You must have Administrator privileges to install Agilent IO Libraries Suite 
NOTE
and to run Connection Expert.
Every IO Libraries Suite installation is a “Full installation”
NOTE
In past versions of IO Libraries, there was an option to install IO Libraries 
as either a Full version or a Runtime version. Beginning with IO Libraries 
Suite 14.0, the installation process provides a Full installation for all users 
(i.e. there is no longer a Runtime installation option). This means that 
every installation now includes the development components of the 
Agilent IO Libraries Suite software, which allows you to develop your own 
I/O programs. If you wish to minimize the size of the installed software, 
select a Custom installation; when you get to the Select Features dialog, 
un-check the manuals and the sample programs.
This section describes how to install Agilent IO Libraries 
Suite on your PC. The process is as follows:

1 Verify that your PC meets the minimum system 
requirements. (See “System Requirements” on page 28.)

2 If you are upgrading to IO Libraries Suite from a previous 
version of IO Libraries, you must remove the instruments 
and interfaces listed below before you upgrade your 
software. This step is necessary in order for these devices 
to obtain the correct drivers to work with Agilent IO 
Libraries Suite.

a Disconnect any USB instruments from your PC.

b Disconnect any Agilent 82357 USB/GPIB interface 
converters from your PC.

c Disconnect any Agilent E8491 IEEE 1394 PC Link to 
VXI interfaces from your PC.

3 Close all other applications on your PC.

4 Insert the Automation- Ready CD with Agilent IO 
Libraries Suite into the CD- ROM drive of your PC. 
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• Wait a few seconds for the auto- run window to appear. 

• If the auto- run window does not appear automatically,

•Click Start > Run... 

•Type <drive>:autorun\auto.exe, where <drive> 
is your CD drive letter.

5 When the auto- run window appears, click Install Software 
once, and wait for the InstallShield Wizard to appear.

Optional: If you want more information before you begin 
the installation, click Connect in 3 Steps and/or Readme.

• The Three- Step Connection Procedure explains how to 
connect an instrument to your PC quickly and easily, 
using the IO Libraries Suite.

• The Read Me file includes last- minute information 
about the IO Libraries Suite software.

6 When the InstallShield Wizard appears, click Next > to 
begin the IO Libraries Suite software installation.

7 Read the License Agreement(s). If you accept the terms, 
click the radio button labeled I accept the terms of the license 
agreement and then click Next > to continue.

8 If you are upgrading to this version of IO Libraries Suite 
from a previous version of IO Libraries or IO Libraries 
Suite, you may see a dialog box similar to Figure 7. 
Notice that you must allow the previous version to be 
removed if you want to install the current version of IO 
Libraries Suite.

a If you are upgrading from Agilent IO Libraries version 
M or earlier, and you have created files in the IO 
Libraries installation folder or any subfolder (for 
example, if you modified IO Libraries sample code and 
saved it in the original samples folder) these files will 
be deleted when you proceed with the upgrade. If you 
wish to keep these files, you must copy them to a safe 
location at this time. 

b Select the check box if you want to save your current 
I/O configuration. 
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•If you select this option, interfaces and instruments 
that were either discovered by, or manually added to, 
either Connection Expert or the old IO Config utility 
will appear when you run Connection Expert.

•If you do not select this option, Connection Expert 
will display only the interfaces and instruments that 
it discovers automatically. Serial and LAN instruments 
will not appear; you will have to add them manually.

c Click Next > to proceed with the installation of IO 
Libraries Suite. 
Figure 7 Upgrading from Previous Version of IO Libraries

9 When the InstallShield Wizard Setup Type dialog box 
appears, as shown, select Typical or Custom, then click OK. 
The Typical setup installs the recommended features for 
your configuration in standard locations on your PC. In a 
Typical setup, if another vendor’s VISA software is already 
installed on this PC, Agilent VISA is installed as 
secondary. If no other vendor’s VISA software is found on 
this PC, Agilent VISA is installed as primary. (See “Using 
Agilent VISA In Side- by- Side Mode” on page 37.)
arted                           31



32

3 Installing IO Libraries Suite
Figure 8 Choosing Setup Type

10 If you chose the Custom setup and you have another 
vendor’s VISA implementation installed on your PC, then 
you will see the dialog box below, which asks whether 
you want to install Agilent VISA as the primary VISA.

Figure 9 Agilent VISA as Primary VISA
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If you do not have another vendor’s VISA installed, you 
will see a similar dialog box, but the check box will be 
selected, indicating that the default is to install Agilent 
VISA as primary.

For details on this topic, see “Using Agilent VISA In 
Side- by- Side Mode” on page 37.

11 If you chose a Custom setup, you will now see the Choose 
Destination Location dialog. 

From this dialog, you may select specific destination 
folders for:

• The IO Libraries Suite software

• Agilent VISA (This choice is enabled only if you have 
not previously installed VXIPlug&Play drivers or other 
VISA components.)

• IVI shared components (This choice is enabled only if 
you have not previously installed IVI shared 
components or IVI drivers.)
NOTE The Agilent VISA and IVI shared components folders chosen during this 
installation will affect the installation location of any related instrument 
drivers that you install later. If you have already installed such drivers, the 
related IO Libraries Suite components will be installed in the folders you 
chose at that time, and these choices will now be disabled.
12 If you chose a Custom setup, you will now see the Select 
Features dialog box.

a Click on any feature in the list to see the feature 
description and the space requirements for the selected 
set of features. It is recommended that you install the 
manuals and sample programs if you plan to program 
with the Agilent IO Libraries; however, you may omit 
them to save space.

b Select the check box for each feature to be installed. 
Clear the check box for each feature to omit.

c When you are done selecting features, click Next >.
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13 The Start Copying Files dialog appears; click Next > to begin 
copying files.

• If the Microsoft .NET Framework version 1.1 has not 
previously been installed on your PC, you will see the 
.NET Framework files being copied onto your computer. 
The Microsoft .NET Framework provides necessary 
infrastructure for Agilent IO Libraries Suite utilities, as 
well as for .NET programming tools and many other 
applications. You will only need to install the .NET 
Framework once, even if you remove and reinstall or 
upgrade your IO Libraries Suite.

• If the Microsoft .NET Framework Service Pack 1 has 
not previously been installed on your PC, you will see 
the Service Pack files being copied onto your computer. 
This Service Pack is necessary for the proper operation 
of Agilent IO Libraries Suite.

• If the IVI (Interchangeable Virtual Instrument) Shared 
Components have not previously been installed on your 
PC, you will now see them being copied onto your 
computer. The IVI Shared Components provides 
necessary infrastructure for Agilent IO Libraries Suite 
utilities, as well as for IVI- COM instrument drivers.

14 After the files have been copied, you may see a dialog 
asking you to restart your PC. This occurs only if you 
have certain I/O hardware configurations. If you choose 
not to reboot at this time, you should reboot before 
running Connection Expert.

15 When the InstallShield Wizard Complete dialog appears, 

a Select the check boxes for the actions that you want to 
do next.

•Select the Read Me file check box if you want to view 
the Read Me file.

•Select the Launch Agilent Connection Expert check box if 
you want to run Connection Expert now. Run 
Connection Expert if you are ready to connect, 
configure, and verify your instruments. If you need to 
install hardware, such as a GPIB card, then wait to 
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run Connection Expert after you have done that 
installation.

b Click Finish.

16 If you are installing Agilent IO Libraries Suite along with 
another instrument, interface, or software product such as 
Agilent VEE or Agilent T&M Toolkit, there may be another 
CD with additional software (drivers, sample programs, 
etc.). If you want to install this additional software,

a Insert the CD into the CD drive on your PC.

b Follow the instructions that came with the CD or the 
hardware or software product.

17 Re- connect any USB instruments or E8491 IEEE- 1394 
FireWire to VXI interfaces that you may have 
disconnected in step 2. Install any new hardware.

18 If Connection Expert is already running, click the 
Refresh All button to identify any hardware you have just 
installed or re- connected.

If Connection Expert is not already running, run it now to 
verify your I/O configuration: In the Windows taskbar 
notification area, click the IO icon (IO Control), then click 
Run Connection Expert.

a Locate your interfaces and instruments in the explorer 
pane. Click on them to see their properties (displayed 
in the right- hand pane). Observe their state, also 
displayed in the right- hand pane: if communication to 
the interface or instrument has been successfully 
established, it will be in the Verified state, denoted by 
a green check mark.

b Change the default I/O configuration (if necessary) by 
clicking Change Properties... in the property pane of the 
interface or instrument you wish to configure.

c If you would like to test your connections manually, 
select your instrument, right- click and choose Send 
Commands To This Instrument.
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If you encounter problems while installing the IO Libraries 
Suite, the following steps may help.

1 Close or Cancel all InstallShield Wizards and other Agilent 
IO Libraries Suite windows. Exit any other applications 
on your system.

2 Browse to the autorun folder of your Automation- Ready 
CD and double- click to run auto.exe. This restarts the 
installation process.

3 If you see the standard InstallShield Wizard, step through 
the installation process as described in this chapter.

4 If you see Modify, Repair, and Remove options, select 
Repair. This will reinstall all installed features of IO 
Libraries Suite. If this does not solve the problem, restart 
the installation again, select Remove, and then reinstall the 
product.

“Error 1935” When Installing Microsoft .NET Framework

The Agilent IO Libraries Suite utilities require the Microsoft 
.NET Framework; if the .NET Framework is not already 
installed on your PC, the IO Libraries Suite installation 
process will attempt to install it. There is a known issue that 
can cause you to receive an “Error 1935” error message 
during this .NET installation.

For steps to resolve this error, go to 
http://www.microsoft.com and search on “Error 1935". 
Follow the instructions given by Microsoft to resolve the 
error.
Changing Your Installation or Removing IO Libraries Suite
1 Click Start > [Settings] > Control Panel > Add or Remove Programs

2 Select Agilent IO Libraries Suite

3 Click Change/Remove

4 Select the action you want to take:
Agilent IO Libraries Suite Getting Started
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• Modify: Adds, replaces, or removes selected features. 
You can change your installation from primary to 
side- by- side or from side- by- side to primary by using 
this option. You can also use this to install manuals or 
sample code if you did not initially install them.

• Repair: Reinstalls all features that are currently 
installed. 

• Remove: Removes the product from your PC.
Keeping Your Software Up To Date
Web resource for the latest IO Libraries Suite software:

www.agilent.com/find/iolib

When you update the IO Libraries Suite software, you may 
choose to preserve your test system configuration. This 
includes the instruments, instrument aliases, interfaces, and 
all related properties.

Web resource for the latest instrument drivers:

www.agilent.com/find/drivers

This Web site includes many types of instrument drivers, 
including IVI- COM and VXIplug&play drivers.
Using Agilent VISA In Side-by-Side Mode
Agilent IO Libraries Suite includes an implementation of 
VISA (Virtual Instrument Software Architecture), one of 
three available application programming instruments for 
instrument control. The VISA standard requires that 
visa32.dll, the dynamic- link library that implements the VISA 
interface, be installed in a prescribed location; therefore, 
only one installed implementation (the primary 
implementation) can fully comply with the standard at any 
one time. Because of this, you must take special care if you 
want to use Agilent IO Libraries Suite alongside any other 
implementation of VISA, such as National Instruments’ 
NI- VISA.
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When you have both Agilent VISA and another vendor's 
VISA installed on the same system, you will need to decide 
whether to let your programs use the primary VISA or 
whether to explicitly direct them to use the Agilent VISA 
implementation. 
NOTE In general, you do not need to install NI-VISA to use National Instruments 
GPIB cards and devices. You can install National Instruments’ NI-488.2 as 
a driver for these devices, and avoid the complications of side-by-side 
operations.
Agilent IO Libraries Suite supports the option to install 
Agilent VISA in side- by- side mode, which allows Agilent 
VISA to be used simultaneously with another vendor's VISA 
implementation. In side- by- side mode, Agilent VISA is 
installed only in a secondary location and therefore does not 
overwrite another vendor's VISA if it is present on the 
computer. 

In general, non- Agilent VISA implementations do not 
support operation as the secondary VISA (in side- by- side 
mode). This means that you must operate Agilent VISA in 
side- by- side mode as the secondary VISA, and the other 
vendor's VISA as primary.

About primary and secondary VISA

• VISA programs normally use visa32.dll, which is 
installed in the Windows system directory. This is the 
primary VISA, as defined by the VISA standard.

• Agilent VISA is implemented in agvisa32.dll, which is 
also installed in the Windows system directory.

• If Agilent VISA is installed as primary, the Agilent version 
of visa32.dll is installed in the Windows system 
directory. It simply forwards all VISA calls to 
agvisa32.dll. 
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• If you install Agilent VISA as primary, all files needed to 
support side- by- side mode are also installed. This means 
that if you subsequently install another vendor's VISA as 
primary, you can still use Agilent VISA as secondary.

If Agilent VISA is installed in side-by-side mode (as the 
secondary VISA)

• agvisa32.dll is installed, but Agilent's visa32.dll is 
not. Thus, it will not overwrite another vendor's 
visa32.dll residing in the standard location.

• Agilent support files are not installed in the bin, 
include, and lib directories of the VISA path (e.g. c:\
program files\visa\winnt), since they would 
overwrite the other vendor's support files. Copies of the 
Agilent versions of the VISA support files reside in the 
agbin, include, and lib subdirectories under 
<VISA path>\agvisa. (These files are installed even when 
Agilent VISA is primary.)

• The IO Control menu and the status bar at the bottom of 
the Connection Expert window will contain a message 
indicating whether Agilent VISA is installed as primary, 
installed as secondary, or installed as primary but 
overwritten by another vendor's VISA. In the latter case, 
Agilent VISA will operate identically to a secondary 
installation.

VISA programs that are linked to the standard VISA DLL 
(e.g. C:\WINDOWS\system32\visa32.dll) will use the 
primary VISA. However, if a VISA program is linked with 
agvisa32.lib or dynamically loads agvisa32.dll, it will 
always use Agilent VISA (regardless of whether Agilent VISA 
is primary or secondary). Addressing is identical regardless 
of whether you are using the primary or secondary VISA in 
your program.

See the Agilent IO Libraries Online Help for more 
information about side- by- side VISA operation.
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Appendix A: Agilent IO Libraries 
Revision History

This appendix includes:

• Pointers to specific information on IO Libraries revisions

• New features of Agilent IO Libraries Suite 14.0 and 14.1

• What happened to IO Config?
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A full matrix of information about past product revisions, 
including PC operating system support and physical interface 
support, is available in the Agilent IO Libraries Suite 
Online Help under Additional Reference Material. The most 
current information will always be provided on the Web at 

http://www.agilent.com/find/iolib_osmatrix

for operating system support information, and

http://www.agilent.com/find/iolib_revmatrix

for general revision information.

If you need to download an older version of the IO Libraries 
or IO Libraries Suite, to support older operating systems or 
older interfaces, you can do so at

http://www.agilent.com/find/iolib
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Agilent IO Libraries Suite provides a new and improved set 
of tools for establishing, verifying, and troubleshooting 
instrument- to- PC connections. Some of the new features of 
the Agilent IO Libraries Suite 14.1 product are described 
here. You can get more information on all these features in 
the Agilent IO Libraries Suite Online Help.

• Agilent IO Libraries Suite 14.1 introduces the Agilent 488 
I/O library, a library for GPIB instrument I/O that 
provides compatibility with existing test & measurement 
code developed using National Instruments’ NI- 488 or 
other similar libraries.

• Introduced in Agilent IO Libraries Suite 14.0, Agilent 
Connection Expert replaces the old IO Config utility with 
an integrated, task- oriented connectivity console. 
Connection Expert is designed for ease of use; it includes 
a task guide to help you quickly access important tasks 
and information, as well as an explorer view that lets you 
see and troubleshoot your connections and devices.

• Introduced in Agilent IO Libraries Suite 14.0, Interactive 
IO is a software utility that lets you interactively send 
commands to instruments and see their responses. It is 
integrated into Connection Expert, and can also be run 
separately from the IO Control. It provides improved ease 
of use over the older VISA Assistant utility.

• LAN local- subnet device discovery is a new feature 
(introduced in Agilent IO Libraries Suite 14.0) that allows 
Connection Expert to automatically discover devices that 
are connected directly, or via a LAN server or gateway, 
on the local subnet of your local area network. This 
means that you do not need to know the IP address or 
hostname of a local- subnet instrument in order to add it 
to your test system.
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• IO Libraries Suite provides extended support of VISA 
aliases. VISA aliases were introduced for USB devices 
only in Agilent IO Libraries M.01.01. Beginning with 
Agilent IO Libraries Suite 14.0, using Agilent Connection 
Expert, you can define VISA aliases for any device or 
interface in your test system. VISA aliases can make your 
test program simpler and more portable.

• IO Libraries Suite includes improved versions of the 
Agilent IO Libraries — VISA, VISA COM, & SICL — with 
module files to facilitate test programming in Microsoft 
.NET languages, and with various defect fixes and 
performance enhancements.
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What Happened to IO Config?
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The Agilent IO Libraries tool called IO Config has been 
replaced, in Agilent IO Libraries Suite, by Connection 
Expert. Connection Expert is an integrated utility that 
provides all the software you need to quickly establish and 
verify connections to your instruments.

Connection Expert provides an explorer view of your test 
system, as well as being the central console for instrument 
connectivity and interface configuration. All the functionality 
of IO Config is now available in Connection Expert.

The IO Config utility is provided in IO Libraries Suite for 
backward compatibility only. The supported configuration 
utility for IO Libraries Suite is Connection Expert. IO 
Libraries Suite installs the unsupported IO Config utility in 
the installation directory (by default, C:\Program Files\
Agilent\IO Libraries Suite), as bin\iocfg32.exe.

VISA Assistant is still installed as part of Agilent IO 
Libraries Suite, but for most users, it has been replaced by 
the Interactive IO utility, which can be accessed from 
Connection Expert or from the IO Control. Interactive IO 
provides a simpler, more intuitive way to send commands to 
instruments and read the returned results. The discovery 
and tree view features of VISA Assistant are replaced and 
improved upon by Connection Expert

Some capabilities of VISA Assistant are not yet available in 
the Interactive IO utility. These include: 

• Memory I/O for VXI and GPIB- VXI interfaces

• Reading and writing of VISA attributes

• Association of VXIplug&play drivers to instruments 

If you need these capabilities, you can start the VISA 
Assistant utility by clicking the IO Control and then VISA 
Assistant, or by clicking Tools > VISA Assistant on the 
Connection Expert menu.
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Glossary

access board

The GPIB interface to which a particular device is 
connected.

Active Controller

See “Controller in Charge”.

address

A string (or other language construct) that uniquely 
locates and identifies a resource. VISA defines an 
ASCII- based grammar that associates address strings with 
particular physical devices or interfaces and VISA 
resources.

Agilent 488

An I/O library provided in Agilent IO Libraries Suite for 
compatibility with existing test & measurement programs 
that were developed using National Instruments’ NI- 488 
or other similar libraries. Agilent 488 supports 
communication with GPIB devices and interfaces, but does 
not support USB, LAN, RS- 232, or VXI communications.

alias

See VISA alias.
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API

Application Programming Interface. The interface that a 
programmer sees when creating an application. For 
example, the VISA API consists of the sum of all of the 
operations, attributes, and events of each of the VISA 
ResourceClasses.

attribute

In VISA and SICL, a value that indicates the operational 
state of a resource. Some attributes can be changed; 
others are read- only.

board

A GPIB interface. It may be a physical board, an adapter 
(such as the 82357 USB/GPIB adapter), or a remote GPIB 
interface.

board descriptor

A handle, returned from ibfind, that uniquely identifies a 
GPIB interface (board) in Agilent 488 original API calls. 
Also called an interface descriptor or board unit 
descriptor.

board-level

Refers to Agilent 488 functions that operate on an 
interface (board), rather than on a device.

bus error

An error that signals failure to access an address. Bus 
errors occur in conjunction with low- level accesses to 
memory, and usually involve hardware with bus mapping 
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capabilities. Bus errors may be caused by non- existent 
memory, a non- existent register, an incorrect device 
access, etc.

bus error handler

Software that runs when a bus error occurs.

CIC

Controller in Charge.

command bytes

GPIB commands encoded as individual bytes. Also called 
GPIB commands or interface messages.

commander

In test- system architectures, a device that has the ability 
to control another device. In a specialized case, a 
commander may also be the device that has sole control 
over another device (as with the VXI Commander/Servant 
hierarchy).

commander session

A session that communicates to the interface’s 
commander. Commander sessions are used when an 
interface is in a non- Controller role.

communication channel

A communication path between a software element and a 
resource. In VISA, “communication channel” is 
synonymous with “session.” Every communication channel 
in VISA is unique.
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Connection Expert

An Agilent software utility that helps you quickly 
establish connections between your instruments and your 
PC. It also helps you troubleshoot connectivity problems. 
Connection Expert is part of the Agilent IO Libraries 
Suite product.

Controller

A device (typically a computer) used to communicate with 
another device or devices (typically instruments). The 
Controller is in charge of communications and device 
operation; it controls the flow of communication and 
performs addressing and other bus management functions.

Controller in Charge

The device currently in control of the GPIB.

device

A unit that receives commands from a Controller. A 
device is typically an instrument, but can also be a 
computer acting in a non- Controller role or another 
peripheral such as a printer or plotter. In VISA, a device 
is logically represented by the association of several VISA 
resources.

device descriptor

A handle, returned from ibdev or ibfind, that uniquely 
identifies a device in Agilent 488 original API calls. Also 
called a device unit descriptor.
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device driver

Software code that communicates with a device: for 
example, a printer driver that communicates with a 
printer from a PC. A device driver may either 
communicate directly with a device by reading to and 
writing from registers, or it may communicate through an 
interface driver.

device session

A session that communicates as a Controller with a single, 
specific device such as an instrument.

device-level

Refers to Agilent 488 functions that operate on a device 
(instrument), rather than on an interface.

direct I/O

Programmatic communication with instruments not 
involving an instrument driver. Direct I/O may be 
accomplished by using an IO Library (VISA, VISA COM, 
SICL, or Agilent 488) or by using direct I/O tools such as 
those provided by Agilent VEE and Agilent T&M Toolkit.

driver

See instrument driver and device driver.

explorer view

The tree view within the Connection Expert window that 
shows all devices connected to a test system.

handler

A software routine that responds to an asynchronous 
event such as an SRQ or an interrupt.
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instrument

A device that accepts commands and performs a test and 
measurement function.

instrument driver

Software that runs on a computer to allow an application 
to control a particular instrument.

Interactive IO

An Agilent application that allows you to interactively 
send commands to instruments and read the results. 
Interactive IO is part of the Agilent IO Libraries Suite 
product.

interface

A connection and medium of communication between 
devices and Controllers. Interfaces include mechanical, 
electrical, and protocol connections.

interface descriptor

A handle, returned from ibfind, that uniquely identifies a 
GPIB interface (board) in Agilent 488 original API calls. 
Also called a board descriptor or board unit descriptor.

interface driver

Software that communicates with an interface. The 
interface driver also handles commands used to perform 
communications on an interface.

interface messages

GPIB commands encoded as individual bytes. Also called 
GPIB commands or command bytes.
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interface session

A session that communicates and controls parameters 
affecting an entire interface.

interrupt

An asynchronous event that requires attention and actions 
that are out of the normal flow of control of a program.

IO Control

The icon in the Windows notification area (usually the 
lower right corner of your screen). The IO Control gives 
you access to Agilent I/O utilities such as Connection 
Expert, Agilent I/O documentation, and VISA options.

IO Libraries

Application programming interfaces (APIs) for direct I/O 
communication between applications and devices. There 
are four Agilent IO Libraries in the Agilent IO Libraries 
Suite: VISA, VISA COM, SICL, and Agilent 488.

Listener

A device that can receive data from the bus when 
instructed (addressed to listen) by the System Controller.

lock

A state that prohibits other users from accessing a 
resource such as a device or interface.

logical unit

A number associated with an interface. A logical unit, in 
SICL and Agilent VEE, uniquely identifies an interface. 
Each interface on the Controller must have a unique 
logical unit.
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mapping

An operation that returns a reference to a specified 
section of an address space and makes the specified range 
of addresses accessible to the requester. This function is 
independent of memory allocation.

non-Controller role

A computer is in a non- Controller role when it acts as a 
device communicating with a computer that is in a 
Controller role.

notification area

The area on the Windows taskbar where notifications are 
posted, typically in the lower right corner of the screen. 
Also called taskbar notification area or Windows 
notification area.

operation

A defined action that can be performed on a resource.

primary VISA

The VISA installation that controls the visa32.dll file. The 
primary VISA will be used by default in VISA 
applications. See also secondary VISA.

process

An operating system component that shares a system's 
resources. A single- process computer system allows only a 
single program to execute at any given time. A 
multi- process computer system allows multiple programs 
to execute simultaneously, each in a separate process 
environment.
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programming alias

See VISA alias.

refresh

In Connection Expert, the action that invokes the 
discovery mechanism for detecting interfaces and 
instruments connected to your computer. The explorer 
view is then refreshed to show the current, discovered 
state of your test system.

register

An address location that contains a value that represents 
the state of hardware, or that can be written into to cause 
hardware to perform a specified action or to enter a 
specified state.

resource (or resource instance)

In VISA, an implementation of a resource class (in 
object- oriented terms, an instance of a resource class). 
For example, an instrument is represented by a resource 
instance.

resource class

The definition of a particular resource type (a class in 
object- oriented terms). For example, the VISA Instrument 
Control resource classes define how to create a resource 
to control a particular capability of a device.

resource descriptor

A string, such as a VISA resource descriptor, that 
specifies the I/O address of a device.
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SCPI

Standard Commands for Programmable Instrumentation: a 
standard set of commands, defined by the SCPI 
Consortium, to control programmable test and 
measurement devices in instrumentation systems.

secondary VISA

A VISA installation that does not install visa32.dll in the 
standard VISA location. The secondary VISA installation 
names its VISA DLL with a different name (agvisa32.dll) 
so that it can be accessed programmatically. The primary 
VISA will be used by default in VISA applications. See 
also primary VISA.

session

VISA term for a communication channel. An instance of a 
communications path between a software element and a 
resource. Every communication channel in VISA is unique.

SICL

Standard Instrument Control Library. SICL is an 
Agilent- defined API for instrument I/O. Agilent SICL is 
one of the IO Libraries installed with Agilent IO Libraries 
Suite.

side-by-side

A side- by- side installation allows two vendors' 
implementations of VISA to be used on the same 
computer. See also primary VISA and secondary VISA.
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SRQ

An IEEE- 488 Service Request. This is an asynchronous 
request (an interrupt) from a remote device that requires 
service. In GPIB, an SRQ is implemented by asserting the 
SRQ line on the GPIB. In VXI, an SRQ is implemented by 
sending the Request for Service True event (REQT).

Standby Controller

A device or interface that has Controller capability, but is 
not currently the Active Controller.

status byte

A byte of information returned from a remote device that 
shows the current state and status of the device. If the 
device follows IEEE- 488 (GPIB) conventions, bit 6 of the 
status byte indicates whether the device is currently 
requesting service.

symbolic name

A name corresponding to a single interface. This name 
uniquely identifies the interface on this Controller or 
gateway. When there is more than one interface on the 
Controller or gateway, each interface must have a unique 
symbolic name.

System Controller

One Controller on a GPIB is the System Controller. This is 
a master Controller; it has the ability to demand control 
and to assert the IFC (Interface Clear) and REN (remote 
enable) lines.

system tray

See notification area.
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Talker

A device that transmits data onto the bus when instructed 
(addressed to talk).

task guide

The information and logic represented in the left pane of 
the Connection Expert window. The task guide provides 
links to actions and information that help guide you 
through the most common I/O configuration tasks.

taskbar notification area

See notification area.

test system

An entire test setup including a Controller (often a PC), 
instruments, interfaces, software, and any remote 
Controllers, instruments, and interfaces that are 
configured to be used as part of the system.

thread

An operating system object that consists of a flow of 
control within a process. A single process may have 
multiple threads, each having access to the same data 
space within the process. Each thread has its own stack, 
and all threads may execute concurrently (either on 
multiple processors, or by time- sharing a single 
processor).

ViFind32

A console application that uses the viFindRsrc and 
viFindNext VISA functions to enumerate all resources 
visible to VISA. This application is useful for verifying 
that all expected interfaces have been configured by 
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Connection Expert, and that the expected devices have 
been attached. ViFind32 is part of the Agilent IO Libraries 
Suite.

virtual instrument

A name given to the grouping of software modules (such 
as VISA resources with any associated or required 
hardware) to give them the functionality of a traditional 
stand- alone instrument. Within VISA, a virtual instrument 
is the logical grouping of any of the VISA resources. The 
VISA Instrument Control Resources Organizer serves as a 
means to group any number of any type of VISA 
Instrument Control Resources within a VISA system.

VISA

Virtual Instrument Software Architecture. VISA is a 
standard I/O library that allows software from different 
vendors to run together on the same platform. Agilent 
VISA is part of the Agilent IO Libraries Suite.

VISA address

A resource descriptor that can be used to open a VISA 
session.

VISA alias

A string that can be used instead of a resource descriptor 
in VISA programs. Using VISA aliases rather than 
hard- coded resource descriptors makes your programs 
more portable. You can define VISA aliases for your 
instruments in Connection Expert.

VISA COM

The VXIplug&play specification for a COM- compliant 
VISA I/O library and its implementation. Agilent 
VISA COM is part of the Agilent IO Libraries Suite.
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VISA Instrument Control Resources

The VISA definition of device- specific resource classes. 
VISA Instrument Control Resources include all 
VISA- defined device and interface capabilities for direct, 
low- level instrument control.

VISA name

The prefix of a VISA address, also called the VISA 
interface ID. The VISA name specifies the interface.

VISA resource manager

The part of VISA that manages resources. This 
management includes support for opening, closing, and 
finding resources, setting attributes, retrieving attributes, 
and generating events on resources.

VISA resource template

The part of VISA that defines the basic constraints and 
interface definition for the creation and use of a VISA 
resource. Each VISA resource must derive its interface 
from the VISA resource template.

VXI Resource Manager

A software utility that initializes and prepares a VXI 
system for use. The VXI Resource Manager is part of the 
Agilent IO Libraries Suite.

Windows notification area

See notification area.
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